import re
regex = re.compile(r"\b[Mm]od(?!e?r|if).*[\W_][hH]\b", flags=re.MULTILINE)
test_str = ("new modified of module h 1\n"
"of mod H\n"
"new of mod_H\n"
"new moderate of mod_H\n"
"to modules (A & h)\n\n"
"new modified and moderate H\n"
"new modification of A mod_A\n"
"to modules (D & E)\n"
"to mode (F, G & A)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")