using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\+62|08)(?:[\s._-]*\d){8,}\b";
string input = @"0823 2371 2318
+62812 2712 2819
Whatsapp :+62 822-5286-0991";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}