re = /(?:\+62|08)(?:[\s._-]*\d){8,}\b/m
str = '0823 2371 2318
+62812 2712 2819
Whatsapp :+62 822-5286-0991'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end