package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\+62|08)(?:[\s._-]*\d){8,}\b`)
var str = `0823 2371 2318
+62812 2712 2819
Whatsapp :+62 822-5286-0991`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}