// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\+62|08)(?:[\s._-]*\d){8,}\b").unwrap();
let string = "0823 2371 2318
+62812 2712 2819
Whatsapp :+62 822-5286-0991";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}