const regex = /(?:\+62|08)(?:[\s._-]*\d){8,}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\+62|08)(?:[\\s._-]*\\d){8,}\\b', 'gm')
const str = `0823 2371 2318
+62812 2712 2819
Whatsapp :+62 822-5286-0991`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}