import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^Banana).*(\\d{6})";
final String string = "Banana lmasfh asfjhas jhona uh3 a y u3u3 303303 ajksdfkas 3jk5hk\n\n"
+ "Banana lmasfh asfjhas jhona uh3 a y u3u3 202202 ajksdfkas 3jk5hk\n\n"
+ "Apple lmasfh asfjhas jhona uh3 a y u3u3 101101 ajksdfkas 3jk5hk";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}