import Foundation
let pattern = #"(?<=^Banana).*(\d{6})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Banana lmasfh asfjhas jhona uh3 a y u3u3 303303 ajksdfkas 3jk5hk
Banana lmasfh asfjhas jhona uh3 a y u3u3 202202 ajksdfkas 3jk5hk
Apple lmasfh asfjhas jhona uh3 a y u3u3 101101 ajksdfkas 3jk5hk
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)