import re
regex = re.compile(r"(?<=^Banana).*(\d{6})", flags=re.MULTILINE)
test_str = ("Banana lmasfh asfjhas jhona uh3 a y u3u3 303303 ajksdfkas 3jk5hk\n\n"
"Banana lmasfh asfjhas jhona uh3 a y u3u3 202202 ajksdfkas 3jk5hk\n\n"
"Apple lmasfh asfjhas jhona uh3 a y u3u3 101101 ajksdfkas 3jk5hk")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")