$re = '/(?<=^Banana).*(\d{6})/m';
$str = 'Banana lmasfh asfjhas jhona uh3 a y u3u3 303303 ajksdfkas 3jk5hk
Banana lmasfh asfjhas jhona uh3 a y u3u3 202202 ajksdfkas 3jk5hk
Apple lmasfh asfjhas jhona uh3 a y u3u3 101101 ajksdfkas 3jk5hk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);