#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\{[a-z0-9_]+\}|"[^"]*"|'[^']*'|\d+(?:\.\d+)?|(?:false|true)|&&|\|\||[<>!=](?:==?)?|[ \t]+)+$"
Local $sString = "{value} >= 5 || {value} < 6.7" & @CRLF & _
"{value} !== 'test' && {value} === true"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")