const regex = /^(?:\{[a-z0-9_]+\}|"[^"]*"|'[^']*'|\d+(?:\.\d+)?|(?:false|true)|&&|\|\||[<>!=](?:==?)?|[ \t]+)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\{[a-z0-9_]+\\}|"[^"]*"|\'[^\']*\'|\\d+(?:\\.\\d+)?|(?:false|true)|&&|\\|\\||[<>!=](?:==?)?|[ \\t]+)+$', 'gm')
const str = `{value} >= 5 || {value} < 6.7
{value} !== 'test' && {value} === true`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}