$re = '/^(?:\{[a-z0-9_]+\}|"[^"]*"|\'[^\']*\'|\d+(?:\.\d+)?|(?:false|true)|&&|\|\||[<>!=](?:==?)?|[ \t]+)+$/m';
$str = '{value} >= 5 || {value} < 6.7
{value} !== \'test\' && {value} === true';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);