re = /^(?:\{[a-z0-9_]+\}|"[^"]*"|'[^']*'|\d+(?:\.\d+)?|(?:false|true)|&&|\|\||[<>!=](?:==?)?|[ \t]+)+$/m
str = '{value} >= 5 || {value} < 6.7
{value} !== \'test\' && {value} === true'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end