package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\{[a-z0-9_]+\}|"[^"]*"|'[^']*'|\d+(?:\.\d+)?|(?:false|true)|&&|\|\||[<>!=](?:==?)?|[ \t]+)+$`)
var str = `{value} >= 5 || {value} < 6.7
{value} !== 'test' && {value} === true`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}