#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(?s)({{Infobox(?:(?!{{Infobox).)*?)\[\[ *fi(?:le|chier) *: *([^\|\]]*)[^\]]*\]\]"
Local $sString = "{{Infobox xyz" & @CRLF & _
"|aaa= Xyz" & @CRLF & _
"|bbb= [[Xyz]]" & @CRLF & _
"|ccc=[[File:xyz.jpg|thumb|Xyz.]]" & @CRLF & _
"|ddd= {{lang|en|xyz}}" & @CRLF & _
"}}" & @CRLF & _
"" & @CRLF & _
"[[File:abc.jpg|thumb|Abc.]]"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)