use strict;
my $str = '{{Infobox xyz
|aaa= Xyz
|bbb= [[Xyz]]
|ccc=[[File:xyz.jpg|thumb|Xyz.]]
|ddd= {{lang|en|xyz}}
}}
[[File:abc.jpg|thumb|Abc.]]';
my $regex = qr/(?s)({{Infobox(?:(?!{{Infobox).)*?)\[\[ *fi(?:le|chier) *: *([^\|\]]*)[^\]]*\]\]/mip;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";