import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(\\{\\{Infobox(?:(?!\\{\\{Infobox).)*?)\\[\\[ *fi(?:le|chier) *: *([^\\|\\]]*)[^\\]]*\\]\\]";
final String string = "{{Infobox xyz\n"
+ "|aaa= Xyz\n"
+ "|bbb= [[Xyz]]\n"
+ "|ccc=[[File:xyz.jpg|thumb|Xyz.]]\n"
+ "|ddd= {{lang|en|xyz}}\n"
+ "}}\n\n"
+ "[[File:abc.jpg|thumb|Abc.]]";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}