re = /(?s)({{Infobox(?:(?!{{Infobox).)*?)\[\[ *fi(?:le|chier) *: *([^\|\]]*)[^\]]*\]\]/mi
str = '{{Infobox xyz
|aaa= Xyz
|bbb= [[Xyz]]
|ccc=[[File:xyz.jpg|thumb|Xyz.]]
|ddd= {{lang|en|xyz}}
}}
[[File:abc.jpg|thumb|Abc.]]'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result