import re
regex = re.compile(r"(?s)({{Infobox(?:(?!{{Infobox).)*?)\[\[ *fi(?:le|chier) *: *([^\|\]]*)[^\]]*\]\]", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("{{Infobox xyz\n"
"|aaa= Xyz\n"
"|bbb= [[Xyz]]\n"
"|ccc=[[File:xyz.jpg|thumb|Xyz.]]\n"
"|ddd= {{lang|en|xyz}}\n"
"}}\n\n"
"[[File:abc.jpg|thumb|Abc.]]")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)