#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(192\.168\.))^(?!(172\.(1[6-9]|2[0-9]|3[0-1])\.))^((([1-9]|1[1-9]|[2-9][0-9]|1[0-9]{2}|2[0-1][0-9]|22[0-3])\.)((0|1[0-9]{0,2}|[2-9][0-9]|2[0-4][0-9]|25[0-5])\.){2}(1[0-9]{0,2}|[2-9][0-9]|2[0-4][0-9]|25[0-4]))$"
Local $sString = "0.0.0.0" & @CRLF & _
"1.0.0.0" & @CRLF & _
"1.0.0.1" & @CRLF & _
"01.0.0.1" & @CRLF & _
"1.00.0.1" & @CRLF & _
"1.0.00.1" & @CRLF & _
"1.0.0.01" & @CRLF & _
"1.0.0.254" & @CRLF & _
"1.0.0.255" & @CRLF & _
"" & @CRLF & _
"10.0.0.1" & @CRLF & _
"11.0.0.1" & @CRLF & _
"11.20.0.1" & @CRLF & _
"11.99.0.1" & @CRLF & _
"11.100.0.1" & @CRLF & _
"" & @CRLF & _
"172.15.255.254" & @CRLF & _
"172.16.0.1" & @CRLF & _
"172.19.254.254" & @CRLF & _
"172.31.255.254" & @CRLF & _
"172.32.0.1" & @CRLF & _
"" & @CRLF & _
"192.168.0.1" & @CRLF & _
"192.169.0.1" & @CRLF & _
"" & @CRLF & _
"223.0.0.1" & @CRLF & _
"223.255.255.254" & @CRLF & _
"223.255.255.255" & @CRLF & _
"224.0.0.1" & @CRLF & _
"255.0.0.0" & @CRLF & _
"255.0.0.1" & @CRLF & _
"255.255.0.1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")