# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!(192\.168\.))^(?!(172\.(1[6-9]|2[0-9]|3[0-1])\.))^((([1-9]|1[1-9]|[2-9][0-9]|1[0-9]{2}|2[0-1][0-9]|22[0-3])\.)((0|1[0-9]{0,2}|[2-9][0-9]|2[0-4][0-9]|25[0-5])\.){2}(1[0-9]{0,2}|[2-9][0-9]|2[0-4][0-9]|25[0-4]))$"
test_str = ("0.0.0.0\n"
"1.0.0.0\n"
"1.0.0.1\n"
"01.0.0.1\n"
"1.00.0.1\n"
"1.0.00.1\n"
"1.0.0.01\n"
"1.0.0.254\n"
"1.0.0.255\n\n"
"10.0.0.1\n"
"11.0.0.1\n"
"11.20.0.1\n"
"11.99.0.1\n"
"11.100.0.1\n\n"
"172.15.255.254\n"
"172.16.0.1\n"
"172.19.254.254\n"
"172.31.255.254\n"
"172.32.0.1\n\n"
"192.168.0.1\n"
"192.169.0.1\n\n"
"223.0.0.1\n"
"223.255.255.254\n"
"223.255.255.255\n"
"224.0.0.1\n"
"255.0.0.0\n"
"255.0.0.1\n"
"255.255.0.1\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.