import Foundation
let pattern = #"^(?!(192\.168\.))^(?!(172\.(1[6-9]|2[0-9]|3[0-1])\.))^((([1-9]|1[1-9]|[2-9][0-9]|1[0-9]{2}|2[0-1][0-9]|22[0-3])\.)((0|1[0-9]{0,2}|[2-9][0-9]|2[0-4][0-9]|25[0-5])\.){2}(1[0-9]{0,2}|[2-9][0-9]|2[0-4][0-9]|25[0-4]))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0.0.0.0
1.0.0.0
1.0.0.1
01.0.0.1
1.00.0.1
1.0.00.1
1.0.0.01
1.0.0.254
1.0.0.255
10.0.0.1
11.0.0.1
11.20.0.1
11.99.0.1
11.100.0.1
172.15.255.254
172.16.0.1
172.19.254.254
172.31.255.254
172.32.0.1
192.168.0.1
192.169.0.1
223.0.0.1
223.255.255.254
223.255.255.255
224.0.0.1
255.0.0.0
255.0.0.1
255.255.0.1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)