using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\?q\](.*?)(?:\[\?p\]|<)";
string input = @"[?q]this is a test[?p]
[?q]this is a test<RANDOM_TAG>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}