// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\?q\](.*?)(?:\[\?p\]|<)").unwrap();
let string = "[?q]this is a test[?p]
[?q]this is a test<RANDOM_TAG>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}