re = /\[\?q\](.*?)(?:\[\?p\]|<)/
str = '[?q]this is a test[?p]
[?q]this is a test<RANDOM_TAG>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end