package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\?q\](.*?)(?:\[\?p\]|<)`)
var str = `[?q]this is a test[?p]
[?q]this is a test<RANDOM_TAG>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}