#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<div[^>]+id\s*=\s*['"]([^'"]+)['"][^>]*>"
Local $sString = "<div id='right_arm'><img src='images/001.gif' /></div>" & @CRLF & _
"" & @CRLF & _
"<div id='right_af_arm'><img src='images/002.gif' /></div>" & @CRLF & _
"" & @CRLF & _
"<div id='fegh_header'><img src='images/003.gif' /></div>" & @CRLF & _
"" & @CRLF & _
"<div id='left_paper'><img src='images/004.gif' /></div>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")