// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<div[^>]+id\s*=\s*['"]([^'"]+)['"][^>]*>"#).unwrap();
let string = "<div id='right_arm'><img src='images/001.gif' /></div>
<div id='right_af_arm'><img src='images/002.gif' /></div>
<div id='fegh_header'><img src='images/003.gif' /></div>
<div id='left_paper'><img src='images/004.gif' /></div>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}