using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div[^>]+id\s*=\s*['""]([^'""]+)['""][^>]*>";
string input = @"<div id='right_arm'><img src='images/001.gif' /></div>
<div id='right_af_arm'><img src='images/002.gif' /></div>
<div id='fegh_header'><img src='images/003.gif' /></div>
<div id='left_paper'><img src='images/004.gif' /></div>
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}