import re
regex = re.compile(r"<div[^>]+id\s*=\s*['\"]([^'\"]+)['\"][^>]*>", flags=re.IGNORECASE)
test_str = ("<div id='right_arm'><img src='images/001.gif' /></div>\n\n"
"<div id='right_af_arm'><img src='images/002.gif' /></div>\n\n"
"<div id='fegh_header'><img src='images/003.gif' /></div>\n\n"
"<div id='left_paper'><img src='images/004.gif' /></div>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")