#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\D"
Local $sString = "+70 888 777 1 1 3"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)