#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s){if +([a-z0-9:]{1,20})+ +(==|>|<|\!=) +([0-9a-z]{1,20})}(.*?){else}(.*?){endif}"
Local $sString = "..." & @CRLF & _
"{if var > 0}" & @CRLF & _
"тут хтмл код" & @CRLF & _
"{else}тут другой хтмл код" & @CRLF & _
"{endif}" & @CRLF & _
"....." & @CRLF & _
"{if id < 6}тут хтмл код{else}тут другой код{endif}" & @CRLF & _
"..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")