using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{if +([a-z0-9:]{1,20})+ +(==|>|<|\!=) +([0-9a-z]{1,20})}(.*?){else}(.*?){endif}";
string input = @"...
{if var > 0}
тут хтмл код
{else}тут другой хтмл код
{endif}
.....
{if id < 6}тут хтмл код{else}тут другой код{endif}
...";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}