package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s){if +([a-z0-9:]{1,20})+ +(==|>|<|\!=) +([0-9a-z]{1,20})}(.*?){else}(.*?){endif}`)
var str = `...
{if var > 0}
тут хтмл код
{else}тут другой хтмл код
{endif}
.....
{if id < 6}тут хтмл код{else}тут другой код{endif}
...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}