import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{if +([a-z0-9:]{1,20})+ +(==|>|<|\\!=) +([0-9a-z]{1,20})\\}(.*?)\\{else\\}(.*?)\\{endif\\}";
final String string = "...\n"
+ "{if var > 0}\n"
+ "тут хтмл код\n"
+ "{else}тут другой хтмл код\n"
+ "{endif}\n"
+ ".....\n"
+ "{if id < 6}тут хтмл код{else}тут другой код{endif}\n"
+ "...";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}