import re
regex = re.compile(r"{if +([a-z0-9:]{1,20})+ +(==|>|<|\!=) +([0-9a-z]{1,20})}(.*?){else}(.*?){endif}", flags=re.DOTALL)
test_str = ("...\n"
"{if var > 0}\n"
"тут хтмл код\n"
"{else}тут другой хтмл код\n"
"{endif}\n"
".....\n"
"{if id < 6}тут хтмл код{else}тут другой код{endif}\n"
"...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")