# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|\|)(?!(?:NULL|[0-9]+(?:\.[0-9]+)?)(?:$|\|))([^|]*)(?=$|\|)/$1/g;t' <<< "TEST|123NjyfjUghfLL|NULL|999|NULL DATA|TEST NULL|TEST|NULL"