import Foundation
let pattern = #"(^|\|)(?!(?:NULL|[0-9]+(?:\.[0-9]+)?)(?:$|\|))([^|]*)(?=$|\|)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"TEST|123NjyfjUghfLL|NULL|999|NULL DATA|TEST NULL|TEST|NULL"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)