import re
regex = re.compile(r"(^|\|)(?!(?:NULL|[0-9]+(?:\.[0-9]+)?)(?:$|\|))([^|]*)(?=$|\|)")
test_str = "TEST|123NjyfjUghfLL|NULL|999|NULL DATA|TEST NULL|TEST|NULL"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)