re = /(^|\|)(?!(?:NULL|[0-9]+(?:\.[0-9]+)?)(?:$|\|))([^|]*)(?=$|\|)/
str = 'TEST|123NjyfjUghfLL|NULL|999|NULL DATA|TEST NULL|TEST|NULL'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result