$re = '/(^|\|)(?!(?:NULL|[0-9]+(?:\.[0-9]+)?)(?:$|\|))([^|]*)(?=$|\|)/';
$str = 'TEST|123NjyfjUghfLL|NULL|999|NULL DATA|TEST NULL|TEST|NULL';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;