package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d{1,13}(?:\.\d{1,2})?|\.[1-9][0-9]?)$`)
var str = `0
0.5
1.55
.5
1234567890123
1234567890123.5
1234567890123.00
.01
.
.,
.0
1.234
5.
12345678901234
12345678901234.56
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}