# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\d{1,13}(?:\.\d{1,2})?|\.[1-9][0-9]?)$"
test_str = ("0\n"
"0.5\n"
"1.55\n"
".5\n"
"1234567890123\n"
"1234567890123.5\n"
"1234567890123.00\n\n\n"
".01\n"
".\n"
".,\n"
".0\n"
"1.234\n"
"5.\n"
"12345678901234\n"
"12345678901234.56\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.