// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d{1,13}(?:\.\d{1,2})?|\.[1-9][0-9]?)$").unwrap();
let string = "0
0.5
1.55
.5
1234567890123
1234567890123.5
1234567890123.00
.01
.
.,
.0
1.234
5.
12345678901234
12345678901234.56
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}