use strict;
my $str = '0
0.5
1.55
.5
1234567890123
1234567890123.5
1234567890123.00
.01
.
.,
.0
1.234
5.
12345678901234
12345678901234.56
';
my $regex = qr/^(?:\d{1,13}(?:\.\d{1,2})?|\.[1-9][0-9]?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}