const regex = /mphb_sc_search-(?!wrapper|form|submit-button-wrapper)([^"]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('mphb_sc_search-(?!wrapper|form|submit-button-wrapper)([^"]*)', 'gm')
const str = `<p class="mphb_sc_search-check-in-date extra">
<div class="mphb_sc_search-wrapper ">
<form method="GET" class="mphb_sc_search-form" action="https:/b3/booking-confirmation/search-results/">
<p class="mphb_sc_search-submit-button-wrapper frm_submit">`;
const subst = `mphb_sc_search-$1 frm_form_field`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);