re = /mphb_sc_search-(?!wrapper|form|submit-button-wrapper)([^"]*)/m
str = '<p class="mphb_sc_search-check-in-date extra">
<div class="mphb_sc_search-wrapper ">
<form method="GET" class="mphb_sc_search-form" action="https:/b3/booking-confirmation/search-results/">
<p class="mphb_sc_search-submit-button-wrapper frm_submit">'
subst = 'mphb_sc_search-$1 frm_form_field'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result