import Foundation
let pattern = #"mphb_sc_search-(?!wrapper|form|submit-button-wrapper)([^"]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p class="mphb_sc_search-check-in-date extra">
<div class="mphb_sc_search-wrapper ">
<form method="GET" class="mphb_sc_search-form" action="https:/b3/booking-confirmation/search-results/">
<p class="mphb_sc_search-submit-button-wrapper frm_submit">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"mphb_sc_search-$1 frm_form_field"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)