use strict;
my $str = '<p class="mphb_sc_search-check-in-date extra">
<div class="mphb_sc_search-wrapper ">
<form method="GET" class="mphb_sc_search-form" action="https:/b3/booking-confirmation/search-results/">
<p class="mphb_sc_search-submit-button-wrapper frm_submit">';
my $regex = qr/mphb_sc_search-(?!wrapper|form|submit-button-wrapper)([^"]*)/mp;
my $subst = 'mphb_sc_search-$1 frm_form_field';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";